Salesforce Service Desk (Billing Ticket) – Intermittent Issues

Incident Report for afr Furniture Rental

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 10:39 EDT

Update

The following steps may help mitigate the impact for affected users:

Refresh the page — In some cases, a hard browser refresh (Ctrl+Shift+R / Cmd+Shift+R) after the error may allow the layout to load on a subsequent attempt.

Clear browser cache — Clearing cached data for the Salesforce domain and reloading the page may allow the layout definition to be fetched fresh from the server, bypassing the affected code path.

Click on OK — In the Error prompt by clicking on OK as well you can resume the operation.
Posted Jun 18, 2026 - 13:21 EDT

Investigating

We are currently experiencing intermittent issues with the Salesforce Service Desk, specifically impacting billing ticket functionality.
Our team is currently investigating the issue and has opened a support ticket with Salesforce for further analysis.

Users may experience delays or errors when accessing or updating billing tickets. We are actively working with Salesforce to resolve the issue as quickly as possible and will provide updates as more information becomes available.
Posted Jun 18, 2026 - 10:44 EDT
This incident affected: Cloud Services (Salesforce).