SalesForce Sync Issue
Incident Report for afr Furniture Rental
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 13:57 EDT
Identified
We see an issue with Salesforce Account and Contacts records not syncing with NAV
Posted Apr 22, 2024 - 17:30 EDT