Power Outage Phoenix

Incident Report for afr Furniture Rental

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 16:57 EDT

Identified

Power is out in Phoenix. We will update you when we have more information.
Posted Jul 28, 2026 - 15:01 EDT
This incident affected: Phoenix AZ (Power - Salt River Project).