Power Outage Jessup 60 and 62

Incident Report for afr Furniture Rental

Resolved

Power has been restored.
Posted Jun 18, 2026 - 10:04 EDT

Investigating

Please be advised that both locations are experiencing a power outage. There is currently no estimated timeline for restoration. We will update as soon as we have more information.
Posted Jun 18, 2026 - 09:19 EDT
This incident affected: Jessup 1 (Power - Baltimore Gas & Electric) and Jessup 2 Events (Power - Baltimore Gas & Electric).