Nashville 370 - Internet is Down
Incident Report for afr Furniture Rental
Resolved
This incident has been resolved.
Posted May 03, 2024 - 22:38 EDT
Update
Comcast is sending a tech to the location to fix the issue.
Posted May 01, 2024 - 10:58 EDT
Identified
We are working with Comcast to resolve this issue.
Posted May 01, 2024 - 08:54 EDT
This incident affected: Nashville, TN 370 (EDI-Comcast, LCB-Cox).