Dispatch Track Wait Times
Incident Report for afr Furniture Rental
Resolved
This incident has been resolved.
Posted May 13, 2024 - 11:45 EDT
Identified
DispatchTrack has identified the issue, and it has been escalated to their engineering team. There is no estimated date for the fix at this time
Posted May 09, 2024 - 12:19 EDT
Investigating
Dispatch track is showing wait orders on the dashboards. They are working to repair this issue.
Posted Apr 12, 2024 - 13:17 EDT