Salesforce sync

Incident Report for afr Furniture Rental

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 20:56 EST

Update

We are working with Salesforce to fix this issue.
Posted Feb 09, 2026 - 18:33 EST

Update

We are still investigating the sync issue between salesforce and nav.
Posted Feb 09, 2026 - 16:08 EST

Update

We are still investigating the sync issue between salesforce and nav.
Posted Feb 09, 2026 - 14:30 EST

Investigating

The data sync between Salesforce and NAV is currently down. You can still log in to Salesforce, but data will not sync to NAV at this time.
Posted Feb 09, 2026 - 12:36 EST
This incident affected: Cloud Services (Salesforce).